How to Install Blender 3.5 on Ubuntu and LinuxMint


In this guide, we will show you how to install Blender 3.5 on Ubuntu and Linux Mint.

Blender is a free and open-source 3D creation software used by animators, game developers, artists, and other professionals to create stunning visual effects, animations, and interactive 3D applications.

What’s New in Blender 3.5

  • On macOS, the 3D Viewport now makes native use of Metal
  • The Graph Editor now has a new easy operator
  • The Build modifier’s new Natural Drawing Speed timing mode
  • Support for USDZ file import and export.

For the complete changelog refer to the release notes

How to Install Blender 3.5 On Ubuntu / Linux Mint

There are three methods to install Blender 3.5 on Ubuntu. You can either use the below methods

  • Third-party PPA
  • Via Snap store
  • Via Flatpak

Method 1: Using Third-party PPA

Step 1: Add the PPA

The first step is to add the Blender PPA (Personal Package Archive) repository to your system. To do this, open the terminal and type:

sudo add-apt-repository ppa:savoury1/blender
sudo add-apt-repository ppa:savoury1/ffmpeg4

Step 2: Update the System

sudo apt update

Step 3: Install Blender 3.5

sudo apt update && sudo apt full-upgrade
sudo apt install blender

Method 2: Using Snap store

Install SNAP Store on the system and install Blender 3.5

sudo apt install snapd && sudo snap install blender — classic

Method 3: Using Flathub

Install Flatpak on your system using the installation guide, if it is already installed you can ignore the step.

flatpak install flathub org.blender.Blender

Run Blender

flatpak run org.blender.Blender


From this tutorial, you have learned how to download and install Blender 3.5 on Ubuntu and Linux Mint

Do let us know your comments and feedback in the comments section below.

If my articles on TipsonUNIX have helped you, kindly consider buying me a coffee as a token of appreciation


Thank You for your support!!

1 thought on “How to Install Blender 3.5 on Ubuntu and LinuxMint”

  1. Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    libopencolorio2.2 : Depends: libminizip-ng3 but it is not installable
    Depends: libpystring0 (>= 1.1.4) but it is not going to be installed
    libopenimageio2.4 : Depends: libptex2 but it is not installable
    libopenshadinglanguage1.12 : Depends: libpartio1 but it is not installable
    libusd : Depends: libptex2 but it is not installable
    E: Unable to correct problems, you have held broken packages.


Leave a Comment